Jumat, 17 Juni 2016

PENCARIAN LINIER/SEKUENSIAL DAN PENCARIAN BINER

Pencarian Linier/Sekuensial

Pencarian Linier atau Pencarian Sekuensial (Bah.Ingg: Linear Search atau Sequential Search) adalah pencarian data secara linier (garis lurus), artinya adalah pencarian dilakukan secara teratur (secara sekuensial) dari awal sampai akhir data (atau bisa juga dari akhir ke awal data). Berikut adalah 2 ciri penting tentang pencarian linier:

-Hanya bagus untuk dipakai pada data yang acak/tak terurut (unsorted)
-Kompleksitasnya adalah O(n)

Pencarian Biner

Pencarian Biner (Bah.Ingg: Binary Search) adalah pencarian data secara eliminasi biner berulang/terus-menerus. Maksudnya adalah pada saat pencarian data, 1 kelompok data yang sudah urut dibagi menjadi 2 subkelompok. Lalu salah satu subkelompok dieliminasi, sehingga ruang lingkup pencarian data menjadi lebih sedikit. Kemudian subkelompok yang tersisa dibagi lagi menjadi 2 subkelompok lagi, demikian dilakukan secara berulang-ulang.

Sebagai contoh, misalnya diinginkan mencari data nama Irawan di sekumpulan data nama yang sudah terurut. Apabila kelompok data ini dibagi 2, ternyata di bagian tengah terdapat nama Leny. Maka subkelompok data sesudah Leny akan dieliminasi, karena tidak mungkin nama Irawan akan terdapat pada data huruf L s/d Z. Sedangkan, subkelompok sebelum Leny, kemudian akan dibagi 2 lagi, dan diperiksa ulang. Ternyata kali ini di bagian tengah terdapat nama Gery. Maka kelompok data sebelum Gery akan dieliminasi, karena tidak mungkin terdapat data Irawan pada huruf A s/d G. Demikian seterusnya terjadi, proses eliminasi ruang lingkup pencarian data menjadi semakin sedikit secara berulang.

Berikut adalah 3 ciri penting mengenai pencarian biner:

-Hanya bisa berfungsi pada data yang sudah terurut (sorted), ini adalah syarat mutlak dari pencarian biner
-Merupakan salah satu contoh penerapan cara kerja dari konsep Divide and Conquer
-Kompleksitasnya adalah O(lg n)



Contoh 1 pencarian linier/sekuensial :
Public Class Form1
Private dataarray() As String
Private data As String
Private n As Integer = 15
Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
Dim i As Integer
For i = 0 To n - 1
If dataarray(i).Trim.ToLo­­ wer = TextBox1.Text.Trim Then
MsgBox("Data ditemukan di posisi ke-" & i, MsgBoxStyle.Information, vbOK)
Exit For
End If
Next
If i = n Then
MsgBox("data tidak ditemukan", MsgBoxStyle.Critical, "hasil")
End If
End Sub
Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load
data = "absolute, absorb, abstain, abstrack, absurd, abundent, abuse, active, accelerate, accent, accept, access, accident, acclaim, accompany"
dataarray = data.Split(",")
End Sub
End Class


Contoh 2:

Public Class Form1
Public data As String Public dataarray() As String Public bilangan() As String Public n As Integer = 20 Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
bilangan = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 10}
For n = 0 To n - 1 If bilangan(n) Mod 2 = 1 Then MsgBox(bilangan(n) & "adalah bilangan ganjil", MsgBoxStyle.OkOnly) End If Next End Sub
End Class 

KUMPULAN TEKS REPORT


Orangutan

               Orangutan or Pongo pygmaeus are primates. Orangutans spend most of their time in trees. every night, orangutans made ​​a nest in a tree. They are endangered because of habitat lost, hunters continue to kill,and exporting orangutan. They just live in the forests of Indonesia, especially on the island of Borneo, and in the north of the island of Sumatra. orangutans are animals that areprotected by the government, because orangutans are endangered animals.
               Orangutans are characterized by long hair, reddish brown.orangutan body length of about 97 cm and weighs about 77 kg.Women are smaller, reaching about 78 cm tall  and weighs only about 38 kg. The man has a swollen cheek and throat pouch hanging. The bag contains air sacks that help generate calls, which can be heard at least 1 km  away. They love to climb trees and swing from one tree to another.
              orangutan diet consists of fruit, but they also eat young leaves, and eggs. Orangutans also eat insects such as ants and termites. By using the branch they eat ants and termites. When a female is ready to mate, she will look for adult males.
              Orangutans are mammals, a single woman give birth about once every four to eight years. Gestation period for orangutans just under nine months, about the same as in humans. Babies stay very close to their mothers for the first three years until their mothers did not consume milk.



Raflesia Arnoldi


            Raflesia Arnoldi" Our country has many kinds of flowers. One of them is called Raflesia Arnoldi. It is the biggest one in the world. It can reach nearly one meter in diameter and 1.40 meters in height.
           It does not have any leaves, stem, or roots and because of lacking choroplasts this plant can not photosynthesize making it a parasite, living on other plants nutrition. .
           The Raflesia plant begins to flower in its tenth year. It blooms three or four times in a year. Before it begins to flower, the leaves and the stem become dry, however, the main root in the ground is still alive. While the flower is blossoming, it has a very unpleasant smell which attracts insects especially green flies. They seem eager to explore the flower. However, if the flies touch the bottom part of the stick-like center, they will die.


Komodo dragons

              Komodo dragons have thrived in the harsh climate of Indonesia’s Lesser Sunda Islands for millions of years, although amazingly, their existence was unknown to humans until about 100 years ago.
                Reaching 10 feet (3 meters) in length and more than 300 pounds (136 kilograms), Komodo dragons are the heaviest lizards on Earth. They have long, flat heads with rounded snouts, scaly skin, bowed legs, and huge, muscular tails.
                 As the dominant predators on the handful of islands they inhabit, they will eat almost anything, including carrion, deer, pigs, smaller dragons, and even large water buffalo and humans. When hunting, Komodo dragons rely on camouflage and patience, lying in wait for passing prey. When a victim ambles by, the dragon springs, using its powerful legs, sharp claws and serrated, shark-like teeth to eviscerate its prey.
                Animals that escape the jaws of a Komodo will only feel lucky briefly. Dragon saliva teems with over 50 strains of bacteria, and within 24 hours, the stricken creature usually dies of blood poisoning. Dragons calmly follow an escapee for miles as the bacteria takes effect, using their keen sense of smell to hone in on the corpse. A dragon can eat a whopping 80 percent of its body weight in a single feeding.
                There is a stable population of about 3,000 to 5,000 Komodo dragons on the islands of Komodo, Gila Motang, Rinca, and Flores. However, a dearth of egg-laying females, poaching, human encroachment, and natural disasters has driven the species to endangered status.


Elephant

                An elephant is the largest and strongest animals which live in land. It is a strange looking animal which has thick legs, huge sides and backs, large hanging ears, a small tail, little pair of eyes, long white tusks and above all, elephant has a long nose called the trunk. An elephant is commonly seen in a zoo because it is hard to find them in their natural habitat.
             The trunk is the elephant’s peculiar feature and it has various usages. The elephant’s trunk can also lift leaves and put them into its mouth. In other word, their trunks serve the elephant as long arm and hand. An elephant looks very clumsy and heavy but an elephant can move very quickly.

             The elephant is considered to be an intelligent animal. Its intelligence combined with its great strength make an elephant a very useful servant to man. Elephant can be trained to serve in various ways such as carrying heavy loads, hunting for tigers and even fighting.

Rabu, 06 April 2016

FUNGSI, KELEBIHAN DAN KEKURANGAN DNS SERVER



Fungsi DNS
·         Menerjemahkan nama komputer ke IP address (memetakan nama komputer menjadi IP address).
·         Kerangka Peraturan pengiriman secara kontroversi menggunakan keuntungan jenis rekod DNS, dikenal sebagai rekod TXT.
·         Menyediakan keluwesan untuk kegagalan computer,Beberapa server DNS memberikan perlindungan untuk setiap domain. Tepatnya,Tiga belas server akar (root server) digunakan oleh seluruh dunia.

Kelebihan DNS
·         Mudah, DNS sangat mudah karena user tidak lagi direpotkan untuk mengingat IP address sebuah komputer, cukup host name.
·         Konsisten, IP address sebuah komputer bisa saja berubah, tapi host name tidak harus berubah.
·         Simple, DNS server mudah untuk dikonfigurasikan (bagi admin).
·         DNS mudah untuk di implementasikan di protocol TCP/IP DNS server mudah untuk di konfigurasikan(Bagi admin) User tidak lagi di repotkan untuk mengingat IP address

Kekurangan DNS
·         User tidak dapat menggunakan nama banyak untuk mencari nama domain baik di internet maupun di intranet.
·         DNS tidak mudah untuk di implementasikan.
·         Tidak konsisten.
·         Tidak bisa membuat banyak nama domain.


FUNGSI , KELEBIHAN DAN KEKURANGAN DHCP SERVER


FUNGSI DHCP 
§  DHCP memiliki fungsi utama mendistribusikan IP address secara otomatis kepada setiap client yang terhubung dengan jaringan komputer
§  DHCP akan memberikan kemudahan bagi seorang network administrator dalam mengelola jaringan komputer, karena alokasi IP address dapat ditentukan secara otomatis dan dalam satu kali kerja
§  DHCP server selain bisa memberikan IP address secara dinamik, juga bisa memberikan IP address secara statis kepada client yang terhubung ke jaringan komputer
§  DHCP memberikan kemudahan dalam proses komunikasi data antar komputer
KELEBBIHAN DHCP SERVER
§  Memudahkan dalam transfer data kepada PC client lain atau PC server. DHCP menyediakan alamat-alamat IP secara dinamis dan konfigurasi lain.
§  DHCP memungkinkan suatu client menggunakan alamat IP yang tidal bisa dipakai oleh client yang lain.
§  DHCP memungkinkan suatu client menggunakan satu alamat IP untuk jangka waktu tertentu dari server.
§  Menghemat tenaga dan waktu dalam pemberian IP.
§  Mencegah terjadinya IP conflict.
KEKURANGAN DHCP SERVER
§  Semua pemberian IP bergantung pada server, maka dari hal itu jika server mati maka semua komputer akan disconnect dan saling tidak terhubung.
  PENGERTIAN DAN  FUNGSI ISP

ISP (Internet Service Provider) adalah perusahaan atau badan usaha yang menjual koneksi internet atau sejenisnya kepada pelanggan. ISP awalnya sangat identik dengan jaringan telepon, karena dulu ISP menjual koneksi atau access internet melalui jaringan telepon. Seperti salah satunya adalah telkomnet instant dari Telkom.

Fungsi ISP

1.    Menyediakan layanan jaringan internet bagi para penggunanya sehingga bisa terhubung ke dalam jaringan internet.
2.    Sebagai perantara dalam menyediakan sambungan internet.
3.    Menghubungkan komputer client ke dalam gateway internet terdekat.
4.    Menyediakan perangkat modem sebagai sambungan dial-up.
5.    Menghubungkan pengguna ke dalam layanan informasi World Wide Web (WWW).
6.    Memungkinkan para pengguna untuk menggunakan layanan surat elektronik (e-mail).
7.    Memungkinkan para pengguna untuk melakukan percakapan suara melalui internet.
8.    Bisa juga melakukan proteksi dari penyebaran virus dengan menerapkan sistem anti virus kepada pelanggannya.

TIPE LAYANAN ISP

Tipe layanan dari ISP biasanya dapat kita kategorikan menjadi 2 bagian yaitu :
 1. Dial on demand Internet Dial on demand ini adalah layanan internet dimana pelanggan tidak terkoneksi secara terus menerus ke internet. Pelanggan akan dibebani biaya berdasarkan lamanya mereka terkoneksi ke internet.
 Contoh layanan internet dial on demand adalah : Telkomnet instant dari Telkom, layanan-layanan dial up dari ISP yang lain, juga beberapa layanan dari ISP wireless local. 
2. Dedicated Internet Pelanggan yang menggunakan dedicated internet akan terhubung terus dengan internet 24/7. Sistem pembayaran dari layanan ini juga biasanya dilakukan per bulan dimana pelanggan akan membayar sesuai dengan paket yang ditawarkan, baik selama sebulan tersebut pengguna memang benar menggunakan internet 24 jam penuh atau tidak. Sistem dedicated ini biasanya mahal, dan biasanya untuk menekan biaya langganan, ISP memberikan beberapa metode untuk menekan harga misalnya dengan membatasi jumlah data yang boleh didownload dan diupload oleh pelanggan selama 1 bulan. Jumlah batasan data ini biasanya disebut dengan quota. Contoh layanan internet dedicated internet adalah layanan-layanan dari Channel 11, ERA AKSES, Speedy dari Telkom dan layanan-layanan dari ISP wireless local.
LAYANAN TRADISIONAL YANG DILAKUKAN OLEH TCP/IP


Berikut ini adalah layanan “tradisional” yg dilakukan TCP/IP :
  1.  Pengiriman file (file transfer). File Transfer Protokol (FTP) memungkinkan  pengguna komputer yg satu untuk dapat mengirim ataupun menerima file ke komputer jaringan. Karena masalah keamanan data, maka FTP seringkali memerlukan nama pengguna (user name) dan password, meskipun banyak juga FTP yg dapat diakses melalui anonymous, alias tidak berpassword. (lihat RFC 959 untuk spesifikasi FTP)
  2.  Remote login. Network terminal Protokol (telnet) memungkinkan pengguna komputer dapat melakukan log in ke dalam suatu komputer didalam suatu jaringan. Jadi hal ini berarti bahwa pengguna menggunakan komputernya sebagai perpanjangan tangan dari komputer jaringan tersebut.( lihat RFC 854 dan 855 untuk spesifikasi telnet lebih lanjut)
  3. Computer mail. Digunakan untuk menerapkan sistem elektronik mail. (lihat RFC 821 dan 822)
  4. Network File System (NFS). Pelayanan akses file-file jarak jauh yg memungkinkan klien-klien untuk mengakses file-file pada komputer jaringan jarak jauh walaupun file tersebut disimpan secara lokal. (lihat RFC 1001 dan 1002 untuk keterangan lebih lanjut)
  5. remote execution. Memungkinkan pengguna komputer untuk menjalankan suatu program didalam komputer yg berbeda. Biasanya berguna jikapengguna menggunakan komputer yg terbatas, sedangkan ia memerlukan sumber yg banyak dalam suatu system komputer. Ada beberapa jenis remote execution, ada yg berupa perintah-perintah dasar saja, yaitu yg dapat dijalankan dalam system komputer yg sama dan ada pula yg menggunakan “prosedure remote call system”, yg memungkinkan program untuk memanggil subroutine yg akan dijalankan di system komputer yg berbeda. (sebagai contoh dalam Berkeley UNIX ada perintah “rsh” dan “rexec”)
  6. name servers. Nama database alamat yg digunakan pada internet (lihat RFC 822 dan 823 yg menjelaskan mengenai penggunaan protokol name server yg bertujuan untuk menentukan nama host di internet.) RFC (Request For Comments) adalah merupakan standar yg digunakan dalam internet, meskipun ada juga isinya yg merupakan bahan diskusi ataupun omong kosong belaka. Diterbitkan oleh IAB (Internet Activities Board) yg merupakan komite independen para peneliti dan profesional yg mengerti teknis, kondisi dan evolusi sistem internet.